'grub.conf'에 해당되는 글 2건

  1. 2010.09.15 grub menu.lst 넌 어디야?!
  2. 2010.02.01 ubuntu 9.10 에서 /dev/fb 만들기 (4)
Linux/Ubuntu2010.09.15 14:01
/boot/grub/menu.lst 에서 (grub)
/boot/grub/grub.conf 로 (grub2) 변경되었다고 한다.
[링크 : http://www.ubuntu.or.kr/viewtopic.php?p=53681]

어쩐지 커널 컴파일 하고 변화가 없더라 -_-
update-grub (grub)
update-grub2 (grub2) 라는걸 사용하라는데
음.. 개인이 직접 컴파일 한 녀석은 어떻게 갱신해야 하려나...
[링크 : http://ubuntu.or.kr/viewtopic.php?p=52374]


더보기


신고
Posted by 구차니

댓글을 달아 주세요

Linux/Ubuntu2010.02.01 16:31
우분투에서는 init 3 명령어로 Xwindow를 종료할수 없다.
정 안되면 magic key를 이용해서 다른 콘솔로 이동한다. ctrl-alt-f1
[링크 : http://simplism.kr/wordpress/?p=258]

grub2는 /boot/grub 와 /etc/default/grub 그리고 /etc/grub.d 로 나뉘는데,
수정은 /etc/default/grub를 한뒤, sudo update-grub로 설정을 변경해준다.
[링크 : http://www.simdoly.com/3935]

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 라는 문구가 기본인데,
vga=791 를 추가해준다. 791의 의미는 1024x768에 16bit color의 framebuffer를 생성하라는 의미이다.
fbset 패키지를 설치해도 /dev/fb가 생성되지는 않는다.
[링크 : http://harrison3001.blogspot.com/2009/09/grub-2-graphical-boot-tips-to-set.html]
[링크 : https://wiki.ubuntu.com/FrameBuffer]


2010.02.22 추가
위의 내용은 ubuntu 9.10 Desktop Edition 에서 테스트 후 올려진 글입니다.
신고
Posted by 구차니

댓글을 달아 주세요

  1. 마추

    ubuntu 9.10 server 버전을 받아 따라 하고 있는데, vga=791로 해도 /dev/fb가 생성되지 않네요.
    혹시나 싶어 grub2 제거하고 이전버전 grub으로 되돌려도 해보고 해도 /dev/fb가 나타날 생각을 안하네요..
    그래서, console상에 image viewer program인 zgv를 다운받아 실행해 봤는데, 정상적으로 잘동작하여 framebuffer는 되는 것 같은데, 혹시 /dev/fb 가 아니더라도 framebuffer를 사용할 수 있을까요?

    embeded 개발 보드 구입전 미리 pc상에서 framebuffer 출력 프로그램을 테스트해 볼려고 하는데, 처음부터 막혀구차니님께 질문 드립니다.
    새버전부터는 /dev/ 대신 /sys/dev/ 를 사용한다는 말이 있어 그쪽 파일을 살펴봐도 framebuffer처럼 생긴 것이 안보이네요..

    2010.02.22 09:45 신고 [ ADDR : EDIT/ DEL : REPLY ]
    • 제가 사용했던 것은 9.10 "Desktop" Edition이었습니다. 아마 서버 에디션에서는 커널에서 FB 지원이 꺼져있는게 아닐까 생각이 됩니다. 커널 소스 받으신뒤 frame buffer를 활성화 하시고 커널변경후 리부팅 해보시면 되지 않을까 추측을 해봅니다.

      많은 도움 드리지 못해 죄송합니다 ㅠ.ㅠ

      결론 : 서버버전의 framebuffer 활성화를 확인해봐야할듯 합니다.

      2010.02.22 09:59 신고 [ ADDR : EDIT/ DEL ]
  2. 마추

    역시 구차님님 지적대로 커널에서 FB 지원이 꺼져있었네요.
    /etc/initramfs-tools/modules에 FB올리라는 명령이 없다보니, 아무리 grub에서 해봤자, 안되었던 거였군요..
    구차니님 힌트로 fbcon과 vesafb를 modules에 올리고 나서 커널 update하니 /dev/fb0가 나타나네요..
    감사합니다.

    2010.02.22 16:14 신고 [ ADDR : EDIT/ DEL : REPLY ]
    • /etc/initramfs-tools 쪽은 처음 들어보네요 ㅎ 한번 공부해봐야겠어요. 좋은정보 감사합니다 ^^

      그래도 해결되었다니 다행이네요.

      2010.02.22 16:24 신고 [ ADDR : EDIT/ DEL ]