'kateinterface'에 해당되는 글 2건

  1. 2009.04.24 kscope on Ubuntu 8.10
  2. 2009.04.20 kscope OTL
Linux/Ubuntu2009.04.24 01:32
kate 패키지가 패키지 매니저에서 제대로 설치 되지 않기 때문에
kscope가 제대로 실행되지 않는다.

그런 이유로 아래의 패키지를 받아서 설치 해야 한다.

kate_3.5.9.dfsg.1-6_alpha.deb 822 KB 2008년 12월 16일 18시 32분 00초
kate_3.5.9.dfsg.1-6_amd64.deb 819 KB 2008년 12월 05일 00시 17분 00초
kate_3.5.9.dfsg.1-6_arm.deb 773 KB 2008년 12월 05일 21시 17분 00초
kate_3.5.9.dfsg.1-6_armel.deb 778 KB 2008년 12월 04일 23시 47분 00초
kate_3.5.9.dfsg.1-6_hppa.deb 840 KB 2008년 12월 09일 06시 47분 00초
kate_3.5.9.dfsg.1-6_i386.deb 806 KB 2008년 12월 03일 21시 17분 00초
kate_3.5.9.dfsg.1-6_ia64.deb 919 KB 2008년 12월 04일 06시 17분 00초
kate_3.5.9.dfsg.1-6_mips.deb 769 KB 2008년 12월 04일 09시 17분 00초
kate_3.5.9.dfsg.1-6_mipsel.deb 763 KB 2008년 12월 04일 21시 32분 00초
kate_3.5.9.dfsg.1-6_powerpc.deb 822 KB 2008년 12월 04일 14시 02분 00초
kate_3.5.9.dfsg.1-6_s390.deb 829 KB 2008년 12월 04일 11시 17분 00초
kate_3.5.9.dfsg.1-6_sparc.deb 790 KB 2008년 12월 04일 21시 32분 00초

[링크 : ftp://ftp.debian.org/debian/pool/main/k/kdebase/]

나의 경우에는 펜티엄4 이므로 i386을 설치 하면된다.

$ file /usr/local/lib/*
libkateinterfaces.so.0:     symbolic link to `libkateinterfaces.so.0.0.0'
libkateinterfaces.so.0.0.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
libkateutils.so.0:          ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
python2.5:                  setgid directory

i386 패키지를 섩치하면 x86-64 버전으로 설치가 된다.


그리고  kscope를 실행하면~


쨔잔~ 이렇게 나온다(아직 쓸줄은 모른다 ㅠ.ㅠ)


[발견 : http://mtsparrow.blogspot.com/2009/02/ubuntu-810-64bit-kscope.html]
[원본 : http://blog.naver.com/sglinux2418/60214557]
신고

'Linux > Ubuntu' 카테고리의 다른 글

gnome-avrdude 컴파일하기  (6) 2009.04.27
ubuntu와 fedora의 비교  (0) 2009.04.26
Ubuntu에 VNC 설정하기  (0) 2009.04.25
kscope on Ubuntu 8.10  (0) 2009.04.24
우분투 설치중  (6) 2009.04.24
ubuntu 8.10 설치 실패.. 아놔 CD 관리 ㅠ.ㅠ  (2) 2009.04.23
Posted by 구차니

댓글을 달아 주세요

Requirements

For running KScope:
  1. The KDE runtime libraries, version 3.3 or above
  2. The Qt runtime libraries, as required by the installed KDE version
  3. Cscope
  4. Exuberant Ctags (KScope will not work with other variants of Ctags)
  5. Graphviz (required as of KScope version 1.3.0).

위에 보이듯이 version 3.3 이상의 QT가 필요 하다는데.. (KDE 3.3)
문제는 요즘꺼는 KDE 4 이다 보니, 제대로 호환이 되지 않아 컴파일시에
kateinterface 쪽에서 문제가 발생한다.

[링크 : http://sourceforge.net/forum/forum.php?thread_id=2574152&forum_id=338423]

아직까지 Kscope가 KDE4에 맞게 나오지 않았고, 나오기 까지는 상당시간이 걸릴것으로 예상이 된다.
그냥.. 다른걸 사용하도록 해야할듯 하다.
신고
Posted by 구차니

댓글을 달아 주세요