프로그램 사용/xen2012.04.11 13:40
아 몰라 대충 일단 full-virtualization으로 설치!

우분투 iso 연결해서 부팅 고고 하면 아래 같이 뜨는데


클릭하면 제목창이 위와 같이 변경되서 마우스 놓으려면 왼쪽 ctrl+alt 누르라고 알려준다.


머 설치 진행 고고


음. 근데 왜 하드가 qemu로 잡히지 -ㅁ-?



아무튼 시간은 재보지 않았지만
4600+x2 에서 가상화로 돌리니 dom0가 domU보다 버벅대는 느낌.. 
Posted by 구차니

댓글을 달아 주세요

프로그램 사용/xen2012.04.11 10:04
다시 시도 해봤는데, 마지막 단계에서
네트워크 설치/이미 설치된 이미지 사용하기 외에는 para-virt를 지원하지 않는다고 배짼다 -_-



"paravirt에서는 URL이나 가져오기 설치만 지원합니다."의 압박 슈밤


그래 그렇게 나온다 이거지?
그래서 URL 지정 똭! (귀찮아서 우분투 iso를 대충 때려 넣음)


아무튼 Virt종류에 xen(paravirt)가 뜨긴하는데


... root가 아니라서 안된다고 배짼다.
xen 정말 널 배째고 싶다 -_-t




아무튼.. 시스템 업데이트 땜시 (400개 패키지 언제 업뎃해 ㅠ.ㅠ)
tftp나 http 설치를 못하니 에효오~

일단 웹서버나 tftp/ftp 서버 가동하고 iso파일을 마운트 해서 다시 시도는 해봐야겠다 ㅠ.ㅠ 
Posted by 구차니

댓글을 달아 주세요

프로그램 사용/xen2012.04.04 23:16
도대체.. 머가 문제일까.. OTL
그냥 i3라도 사고 할까 하아...



설치를 완료할 수 없음: 'POST 작업 실패: xen_post: xen 데몬으로부터 오류: <Fault 3: 'virt0'>'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1899, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/pymodules/python2.7/virtinst/Guest.py", line 1223, in start_install
    noboot)
  File "/usr/lib/pymodules/python2.7/virtinst/Guest.py", line 1291, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 1686, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: POST 작업 실패: xen_post: xen 데몬으로부터 오류: <Fault 3: 'virt0'> 

겁나 검색해보니
/usr/share/qemu/keymap 이 있어야 하는데
/usr/share/qemu-linaro/keymap만 존재한다 -_-

아무튼 이거 하나 해주면 실행됨 -_-
$ sudo ln -s /usr/share/qemu-linaro /usr/share/qemu 

[링크 : https://bugs.launchpad.net/ubuntu/+source/xen/+bug/811635]



'프로그램 사용 > xen' 카테고리의 다른 글

xen 전가상화로 설치하기  (0) 2012.04.11
xen paravirt로 설치하기....?  (0) 2012.04.11
xen / qemu keymap 심볼릭 링크  (0) 2012.04.04
xend 실행안하고 virt-manager 실행하기 (으악!)  (0) 2012.04.04
qemu-dm not found  (4) 2012.04.03
xen에서 cdrom 사용하기  (0) 2012.04.03
Posted by 구차니

댓글을 달아 주세요

프로그램 사용/xen2012.04.04 22:05
아무생각 없이
$ sudo vi /etc/xen/xend-config.sxp 
(xend-unix-server no) 

이렇게 주석만 풀어주고 실행했더니 아래와 같은 에러가 발생한다.


내용을 yes로 수정후, 서비스만 재시작 해주면 해결된다.
$ sudo service xend restart
 * Restarting Xen daemons                                                [ OK ] 
 

'프로그램 사용 > xen' 카테고리의 다른 글

xen paravirt로 설치하기....?  (0) 2012.04.11
xen / qemu keymap 심볼릭 링크  (0) 2012.04.04
xend 실행안하고 virt-manager 실행하기 (으악!)  (0) 2012.04.04
qemu-dm not found  (4) 2012.04.03
xen에서 cdrom 사용하기  (0) 2012.04.03
Xen (ubuntu 11.10) with AMD 4200+x2  (0) 2012.04.01
Posted by 구차니

댓글을 달아 주세요

프로그램 사용/xen2012.04.03 22:51

"인터페이스 목록을 위한 HAL을 초기화 할 수 없음" 빨간 느낌표 무시하고 그냥 다음을 누르면


"'/usr/lib64/xen/qemu-dm' not found" 라는 에러가 발생한다.


우분투 데스크탑 11.10 64bit를 깔았는데
/usr/lib/xen-4.0.1 은 존재하지만
/usr/lib64가 존재하지 않는다.

그런 이유로 아래처럼 심볼릭 링크를 걸어준다.

$ sudo mkdir /usr/lib64
$ sudo ln -s /usr/lib64/xen /usr/lib/xen-4.0.1  

[링크 : http://bderzhavets.wordpress.com/2011/07/23/build-xen-4-1-1-on-ubuntu-11-10/]
[링크 : http://www.xen-support.com/?p=408]



아무튼 그러면 생성하다 말고 이런 에러를 또 뱉어낸다 -_-


---
2012.04.04
루프 디바이스
[링크 : http://www.linuxhelp.in/2011/06/error-device-vbd-could-not-be-connected.html ]

2012.04.14
$ sudo vi /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash max_loop=64"
$ sudo update-grub
 
[링크 : http://lists.debian.org/debian-user/2006/12/msg00901.html]

도움이 될듯한 링크 후우.. 언제 또 읽어보나?
[링크 :  http://wiki.libvirt.org/page/VirtualNetworking]

'프로그램 사용 > xen' 카테고리의 다른 글

xen / qemu keymap 심볼릭 링크  (0) 2012.04.04
xend 실행안하고 virt-manager 실행하기 (으악!)  (0) 2012.04.04
qemu-dm not found  (4) 2012.04.03
xen에서 cdrom 사용하기  (0) 2012.04.03
Xen (ubuntu 11.10) with AMD 4200+x2  (0) 2012.04.01
가상화는 무리인가...  (2) 2012.03.31
Posted by 구차니

댓글을 달아 주세요

  1. 이제 저도 우분투... 한번 깔아보고 공부할려고 합니다. (이번엔 진짜로^^)
    근데 남는 PC가 어딧더라?ㅠㅠ

    2012.04.04 08:56 [ ADDR : EDIT/ DEL : REPLY ]
    • 어떠한 목적이 없으면 흐지부지 해지는게 아무래도 리눅스라 ㅎㅎ
      그냥 공부라는 목적이라면 추천하고 싶지는 않아요
      특히 한국에서는 아직 말이죠 ㅠ.ㅠ


      이번에 국민은행도 오픈뱅킹으로 전환한거 같긴한데 다른 사이트들도 되는진 한번 확인해봐야겠네요 ㅋ

      2012.04.04 09:24 신고 [ ADDR : EDIT/ DEL ]
    • 키키.. 목적이 있죠.. 아주 급해서 문제지...ㅠㅠ
      ROS를 한번 접근해볼까 해요^^
      우분투의 세계로.. 문젠..아직 PC가 ㅠㅠ
      회사에 굴러댕기는 PC를 찾아야겠어요^^

      2012.04.04 11:08 [ ADDR : EDIT/ DEL ]
    • http://www.ros.org/wiki/

      요즘 인기인가봐요? ㅎ
      정 안되면 노트북 중고로 하나 사시거나
      데탑 하나 20정도 해서 질러버리세요 ㅋㅋ

      G600대 로 대충 견적 잡으니 20 중반에 하드뺴고 구매 가능하겠던데요? ㅎ

      2012.04.04 11:19 신고 [ ADDR : EDIT/ DEL ]

프로그램 사용/xen2012.04.03 07:44
cdrom 사용하는건 여전히 미궁... OTL
그냥 ISO로 깔라는 신의 계시인가? -_-

$ sudo virsh -c xen:/// capabilities

더보기


$ sudo cat /var/log/xen/xend-debug.log 

더보기


[링크: https://bugzilla.redhat.com/show_bug.cgi?id=585460]

[링크 : http://docs.fedoraproject.org/...Creating_guests_with_virt_manager.html]
[링크 : http://www.linuxquestions.org/questions/linux-software-2/how-to-use-physics-cdrom-in-xen-695471/]

---
2012.4.4 추가
혹시나 해서 /etc를 hda로 뒤졌는데 cd롬이 hda로 인식하도록 py 파일들을 작성한듯 하다 -_-
usb cdrom이라서 그런지 /dev/sr0 로 인식을 해서 virt-manager에서 인식을 못하는 걸려나?

[링크 : http://www.option-c.com/xwiki/Xen_CDROM_Support]
 
Posted by 구차니
TAG Xen, xen cdrom

댓글을 달아 주세요

프로그램 사용/xen2012.04.01 16:22
머.. 일단 AMD 4200+x2 에서 실행했더니 실행은 되는데 


CDROM 또는 DVD사용에서 인식을 하지 못한다.

cd 를 넣고 mount 명령으로 확인해 보니 읭?
/dev/sr0 on /media/floppy0 type iso9660 
웬 뜬금없는 floppy0 ?!?!?!?!

머 안되면 그냥 iso로 하면되지 머 쫄지마!


vmware 설정하듯 메모리 와 사용할 cpu 와 메모리 용량을 설정해주고


하드도 설정해주고


근데 왜 또 네트워크가 말썽이니 ㅠ.ㅠ


----
그나저나 무슨 차이가 있어서 안되나 궁금해서 cpuinfo를 확인해보니
amd용으로는 svm이 있다는데 그런것도 없고 hypervisor가 존재한다.
$ cat /proc/cpuinfo
processor    : 0
vendor_id    : AuthenticAMD
cpu family    : 15
model        : 107
model name    : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping    : 2
cpu MHz        : 800.000
cache size    : 512 KB






fpu        : yes
fpu_exception    : yes
cpuid level    : 1
wp        : yes
flags        : fpu de tsc msr pae cx8 apic cmov pat clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 hypervisor lahf_lm cmp_legacy extapic cr8_legacy 3dnowprefetch

bogomips    : 5488.05
TLB size    : 1024 4K pages
clflush size    : 64
cache_alignment    : 64
address sizes    : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
$ cat /proc/cpuinfo
processor    : 0
vendor_id    : AuthenticAMD
cpu family    : 15
model        : 107
model name    : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping    : 2
cpu MHz        : 2200.000
cache size    : 512 KB
physical id    : 0
siblings    : 2
core id        : 0
cpu cores    : 2
apicid        : 0
initial apicid    : 0
fpu        : yes
fpu_exception    : yes
cpuid level    : 1
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips    : 4389.91
TLB size    : 1024 4K pages
clflush size    : 64
cache_alignment    : 64
address sizes    : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

리부팅 해서 확인해보니 intel이던 amd던 Dom0로 부팅하면 hypervisor가 뜨게 된다.

[링크: http://blog.bradiceanu.net/2009/07/20/linux-proccpuinfo-flags/]
2012/01/25 - [프로그램 사용/xen] - xen 사용가능한 cpu 확인하기 

'프로그램 사용 > xen' 카테고리의 다른 글

qemu-dm not found  (4) 2012.04.03
xen에서 cdrom 사용하기  (0) 2012.04.03
Xen (ubuntu 11.10) with AMD 4200+x2  (0) 2012.04.01
가상화는 무리인가...  (2) 2012.03.31
ubuntu 11.10 xen 커널로 부팅하도록 grub 수정하기  (0) 2012.03.31
xen on Ubuntu 11.10 with Xnote LW25  (0) 2012.03.29
Posted by 구차니

댓글을 달아 주세요

프로그램 사용/xen2012.03.31 22:55
LW25 이녀석 cpu 듀얼 코어인데다가 가상화도 지원되서 쓸만할줄 알았더니...
xen으로 돌리면 열이 70도 정도까지 보고되는게 치솟고
xen이 아닌 일반 커널로 돌리면 49도 정도로 낮아진다. (11.10 기준)

xen Dom0 에서도 실제 리포팅 되는 cpu 사용량이 맞지 않는걸까..
아니면 가상화 부분이 활성화 되면서 cpu 발열이 올라가는 걸까? 

---
cpu 실 사용량을 확인하는 방법
xentop을 쓰면된다고 한다.
[링크 : http://serverfault.com/questions/334613/how-do-i-tell-real-cpu-load-in-a-xen-environment]

--- 
2012.4.1 추가

Xen 이 아닌 커널로 돌릴때 23W 정도 소비

Motorola | A853 | Normal program | Center-weighted average | 1/15sec | F/2.8 | 0.00 EV | 4.0mm | ISO-199 | Off Compulsory | 2012:04:01 17:17:49

Xen 커널로 돌릴때 33W 정도 소비

Motorola | A853 | Normal program | Center-weighted average | 1/15sec | F/2.8 | 0.00 EV | 4.0mm | ISO-199 | Off Compulsory | 2012:04:01 17:21:28

 
cpu 사용량은 둘다 동일한 0% 이지만
발열이 팍팍 오르는것과 더불이 전략소비량이 이렇게 팍팍 오르는걸 보면..
xen 자체가 부하가 많이 걸리는 느낌이다. 
Posted by 구차니

댓글을 달아 주세요

  1. 히히.. 한달이 끝나버렸어요... 그래도 한달의 시작이 한주의 시작과 같으니 이 번 4월은 잘 보내보자구요.^^
    즐겁고 활기차게^^ 화이팅입니다^^

    2012.04.01 15:23 [ ADDR : EDIT/ DEL : REPLY ]
    • pinkwink 님도 좋은일로 가득한 4월 되세요~ ㅎ
      연애운이라도 몰아드려야 하나요? ㅋ

      2012.04.01 15:36 신고 [ ADDR : EDIT/ DEL ]

프로그램 사용/xen2012.03.31 12:45
/etc/default/grub 파일의
GRUB_DEFAULT = 0 을 다른걸로 바꾸어 주면 된다는데

GRUB_DEFAULT='Example GNU/Linux distribution'
이런방식도 지원한다고 해서 xen 의 menu이름을 넣어줘도 안되고

20_linux_xen 이런식으로 되어 있어서(/etc/grub.d/)
GRUB_DEFAULT=20 해도 안되고 -_-

[링크 : http://www.gnu.org/software/grub/manual/html_node/default.html]
[링크 : http://www.gnu.org/software/grub/manual/grub.html]

미친척 그냥 2번으로 하니 문제없이 xen 커널로 부팅된다 -_-

- Edit "/etc/default/grub"
- In my case I put "GRUB_DEFAULT=2" (index of XEN kernel was two)
- update-grub
- restart 

[링크 :  http://blogs.deepal.org/2012/02/install-xen-dom0-and-domu-on-ubuntu.html]  


---
2012.4.14 추가
아래의 명령어를 실행해서 나오는 xen 커널의 순서를 입력해주면 된다.
$ grep menuentry /boot/grub/grub.cfg 

[링크 : http://wiki.debian.org/Xen]
 
Posted by 구차니
TAG Xen, xen grub

댓글을 달아 주세요

프로그램 사용/xen2012.03.29 21:52
Ubuntu 11.10 Desktop 64bit 버전으로 설치했을 경우 아래의 명령어를 그대로 붙여넣으면 된다.
$ sudo apt-get install xen-hypervisor-4.1-amd64 xen-utils-4.1 xenwatch xen-tools xen-utils-common xenstore-utils
$ sudo apt-get install virtinst virt-viewer virt-manager

더보기

 
[링크 : http://www.beyondlinux.com/2011/11/02/install-xen-4-1-and-setup-your-cloud-os-on-ubuntu-11-10/]  

그리고 나서 하라는대로 해보니까 먼가 되긴된다.
저번에는 xm info 할때 에러가 났는데 커널이 문제였던게 확실한듯.
아무튼, 1.8인치 하드의 저렴한(!) 성능 문제도 있지만 11.10이 부팅이 빠름에도 불구하고
xen 커널로 들어가서 화면이 나오기 까지 체감적으로 3분 이상 걸린 느낌이다. (정상 부팅은 1분 미만)

$ uname -a
Linux xen64bit 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ sudo xm list
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0  1887     2     r-----     59.7

$ sudo xm info
host                   : xen64bit
release                : 3.0.0-12-generic
version                : #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011
machine                : x86_64
nr_cpus                : 2
nr_nodes               : 1
cores_per_socket       : 2
threads_per_core       : 1
cpu_mhz                : 1828
hw_caps                : bfebfbff:20000800:00000000:00000940:0000e3bd:00000000:00000001:00000000
virt_caps              :
total_memory           : 2038
free_memory            : 126
free_cpus              : 0
xen_major              : 4
xen_minor              : 1
xen_extra              : .1
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : unavailable
xen_commandline        : placeholder
cc_compiler            : gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
cc_compile_by          : zulcss
cc_compile_domain      : ubuntu.com
cc_compile_date        : Tue Oct 11 07:31:13 UTC 2011
xend_config_format     : 4

$ sudo brctl show
bridge name     bridge id               STP enabled     interfaces
virbr0          8000.000000000000       yes 


---
2012.3.31 추가

$ sudo vi /etc/xen/xend-config.sxp 


$ vi ~/.bashrc
$ sudo -i
# vi ~/.bashrc


# virsh version

라이브러리에 대해 컴파일됨: libvir 0.9.2

사용중인 라이브러리: libvir 0.9.2

사용중인 API: Xen 3.0.1

실행중인 하이퍼바이저: Xen 4.1.0


# virt-manager

  

으악 안되잖아! ㅠ.ㅠ

---
2012.4.2 추가
친구에 게물어보 니 가상 화지원하 지않으 면위와같 이나온다고한다.
그래서확인 겸 amd cpu에 서 secure virtual machine 옵션 을bios에 서끄 고해보 니동일하 게발생한다.
즉, cpu 에 서가상화 를지원해 도bios에 서해 당옵션 을끄 면위 와같 이 "가상화 를지원하 지않는 것같습니다"라 는오류 가뜬다.
 

Posted by 구차니
TAG Xen

댓글을 달아 주세요