embeded/raspberry pi2020. 4. 27. 21:13

gst-launch-1.0이 정상적으로 설치되지 않아서 다른방법을 찾는데 쉽진 않네?

 

서버(라즈베리 파이 2)

raspivid -t 0 -l -o tcp://0.0.0.0:3333

 

클라이언트(라즈베리 파이 3 / SPI 60Hz LCD)

vlc tcp/h264://192.168.66.154:3333

[링크 : https://raspberrypi.stackexchange.com/questions/23182/]

  [링크 : https://qastack.kr/raspberrypi/23182/how-to-stream-video-from-raspberry-pi-camera-and-watch-it-live]

 

출력에는 문제 없지만 버퍼링이 심해서 2초 정도 재생되고 5초 멈추고 그런 식으로 재생된다.

다른 옵션이나 네트워크 문제는 아닌지 조금더 봐야 할 듯

 

 

+

2015년에 했던거라 그런지 이제는 안된다.

2016/05/27 - [embeded/raspberry pi] - 라즈베리 파이 gstreamer / vlc ... 실패?

2015/09/20 - [embeded/raspberry pi] - 라즈베리 파이 gstreamer 시도

 

아래 패키지 깔아보려는데 충돌나서 안되고

그래서 다른거 해보려니 여전히 gst-launch-1.0이 없다. 도대체 머가 문제일까...

$ sudo apt-get install gstreamer1.0 gstreamer1.0-omx
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-python-dbg-plugin-loader'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-ugly-amr'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-videosink'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-alsa'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-ugly-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-ugly-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-base-apps'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-rtsp-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'libgstreamer1.0-dev'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-tools'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-python3-dbg-plugin-loader'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-good'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-qapt'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'libgstreamer1.0-0-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-espeak'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-nice'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-rpi-dbgsym'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-rpi'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-opencv'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-rpi-config'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-videosource'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-crystalhd'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-fluendo-mp3'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-rtsp'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-bad'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-base'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-audiosource'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-gnonlin-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-gnonlin-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-pipewire'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-bad-videoparsers'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-really-bad'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-clutter'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-pulseaudio'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-pocketsphinx'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-bad-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-bad-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-gtk3'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-visualization'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-bad-faad'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-generic'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-lame'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-x'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-python-plugin-loader'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-rtp'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-generic-dbgsym'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-gnonlin'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-vaapi-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-generic-config'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-libav'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-base-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-good-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-base-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-good-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-dvswitch'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-clutter-3.0'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-vaapi'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-libav-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-packagekit'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-python3-plugin-loader'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'libgstreamer1.0-0'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-dbg'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-omx-bellagio-config'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-gl'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-plugins-ugly'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-doc'을(를) 선택합니다
주의, 정규식 'gstreamer1.0'에 대해 'gstreamer1.0-audiosink'을(를) 선택합니다
주의, 'gstreamer1.0-plugins-bad-faad' 대신에 'gstreamer1.0-plugins-bad' 패키지를 선택합니다
주의, 'gstreamer1.0-plugins-bad-videoparsers' 대신에 'gstreamer1.0-plugins-bad' 패키지를 선택합니다
주의, 'gstreamer1.0-plugins-ugly-amr' 대신에 'gstreamer1.0-plugins-ugly' 패키지를 선택합니다
gstreamer1.0-alsa is already the newest version (1.14.4-2).
gstreamer1.0-libav is already the newest version (1.15.0.1+git20180723+db823502-2).
gstreamer1.0-plugins-bad is already the newest version (1.14.4-1+b1).
gstreamer1.0-plugins-base is already the newest version (1.14.4-2).
gstreamer1.0-x is already the newest version (1.14.4-2).
libgstreamer1.0-0 is already the newest version (1.14.4-1).
libgstreamer1.0-0 패키지는 수동설치로 지정합니다.
gstreamer1.0-omx is already the newest version (1.14.4-1+rpt1).
gstreamer1.0-omx-rpi is already the newest version (1.14.4-1+rpt1).
gstreamer1.0-omx-rpi 패키지는 수동설치로 지정합니다.
gstreamer1.0-omx-rpi-config is already the newest version (1.14.4-1+rpt1).
gstreamer1.0-omx-rpi-config 패키지는 수동설치로 지정합니다.
gstreamer1.0-plugins-good is already the newest version (1.14.4-1+rpt1).
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
 gstreamer1.0-omx-dbg : 의존: gstreamer1.0-omx (= 1.0.0.1-0+rpi12+jessiepmg) 하지만 1.14.4-1+rpt1 패키지를 설치할 것입니다
 gstreamer1.0-python3-dbg-plugin-loader : 충돌: gstreamer1.0-python3-plugin-loader 하지만 1.14.4-1 패키지를 설치할 것입니다
 gstreamer1.0-python3-plugin-loader : 충돌: gstreamer1.0-python3-dbg-plugin-loader 하지만 1.14.4-1 패키지를 설치할 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.


$ sudo apt-get install gstreamer1.0-omx-rpi
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
gstreamer1.0-omx-rpi is already the newest version (1.14.4-1+rpt1).
gstreamer1.0-omx-rpi 패키지는 수동설치로 지정합니다.
0개 업그레이드, 0개 새로 설치, 0개 제거 및 0개 업그레이드 안 함.


$ sudo apt-cache search gst-launch
rygel-gst-launch - GNOME UPnP/DLNA services - gst-launch plugin
pi@raspberrypi:~ $ sudo apt-get install rygel-gst-launch
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
The following additional packages will be installed:
  gstreamer1.0-plugins-ugly libgee-0.8-2 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libmediaart-2.0-0
  libopencore-amrnb0 libopencore-amrwb0 librygel-core-2.6-2 librygel-db-2.6-2
  librygel-renderer-2.6-2 librygel-server-2.6-2 libsidplay1v5 rygel
제안하는 패키지:
  sidplay-base rygel-playbin rygel-preferences rygel-ruih rygel-tracker tumbler
다음 새 패키지를 설치할 것입니다:
  gstreamer1.0-plugins-ugly libgee-0.8-2 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libmediaart-2.0-0
  libopencore-amrnb0 libopencore-amrwb0 librygel-core-2.6-2 librygel-db-2.6-2
  librygel-renderer-2.6-2 librygel-server-2.6-2 libsidplay1v5 rygel rygel-gst-launch
0개 업그레이드, 14개 새로 설치, 0개 제거 및 0개 업그레이드 안 함.
4,943 k바이트 아카이브를 받아야 합니다.
이 작업 후 9,770 k바이트의 디스크 공간을 더 사용하게 됩니다.
계속 하시겠습니까? [Y/n]


Posted by 구차니

댓글을 달아 주세요